Schedule Maintenance on Tutor Portal & CRM from 2023-11-18 08:00 AM EDT to 2023-11-19 02:00 PM EDT

Scheduled maintenance Customer Management System & Internal Portal Tutor Portal
2023-11-18 08:00 AM EDT · 1 day, 6 hours

Updates

Monitoring

Unfortunately, this effort is taking far longer than expected and we are extending the maintenance window until Sunday, 11/19 at 2pm ET. We apologize for the issues here. We’re working rapidly to ensure the system is up and running as soon as possible. Thank you for your patience.

November 18, 2023 · 08:57 PM EDT
Update

Note that we we are taking a bit longer than expected. We expect the system to be back online by 8pm ET.

We’ll provide additional updates as available if this timeline changes. Thank you for your patience.

November 18, 2023 · 01:56 PM EDT
Scheduled

This Saturday, November 18th from ~8am ET - 4pm ET our tutor portal (https://my.studypoint.com) will be down for scheduled maintenance and structural upgrades.

If you have a tutoring session during this window, you can access the whiteboard system directly at https://whiteboard.prepnow.com. If you anticipate a session next Saturday, I encourage you to test your login credentials this week to avoid stress on Saturday. I’m happy to offer guidance on login details throughout the week.

If you need access to student results for practices tests or homework during that window, please coordinate with your student as you will not be able to access your portal to view their results. The student portal however will be untouched during this time.

Please feel free to reach out to portal_help@studypoint.com if you have any questions or concerns.

November 13, 2023 · 01:45 PM EDT

← Back